Twint payment issues

Incident Report for SKY Switzerland status page

Update

We are continuing to investigate this issue.
Posted Aug 11, 2025 - 10:46 CEST

Investigating

We are currently investigating this issue.
Posted Aug 10, 2025 - 08:13 CEST
This incident affects: Sky.ch homepage, Sky Show service, Sky Sport service, and Sky Store service.